What’s Vulnerable › Vulnerabilities
CVE-2026-86430: league/commonmark before 2.9.1 Denial of Service via parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-407
Description
league/commonmark versions before 2.9.1 contain multiple denial of service vulnerabilities in fenced code block detection, reference link label lookup, and emphasis delimiter processing that perform super-linear work on crafted input. Attackers can submit specially crafted Markdown with long backtick runs, nested brackets, or delimiter sequences to consume disproportionate CPU time and prevent legitimate requests from completing.
Affected products
- thephpleague commonmark: before 2.9.1 — fixed in 2.9.1
How to fix
Upgrade to a fixed version: thephpleague commonmark 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/thephpleague/commonmark/security/advisories/GHSA-j8pm-gj4c-rq4x
- https://www.vulncheck.com/advisories/league-commonmark-before-2.9.1-denial-of-service-via-parsing
Get alerted when CVE-2026-86430 or the next vulnerability affects your stack