What’s Vulnerable › Vulnerabilities
CVE-2026-86432: commonmark 2.0.0 before 2.8.4 Denial of Service via XML
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-10-08
- Weakness: CWE-405
Description
commonmark versions from 2.0.0 before 2.8.4 contain a denial of service vulnerability in XmlRenderer that emits depth-proportional indentation for every XML tag. Attackers can provide deeply nested Markdown or AST structures to cause quadratic memory consumption and output amplification, exhausting server resources.
Affected products
- thephpleague commonmark: from 2.0.0 before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: thephpleague commonmark 2.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/thephpleague/commonmark/security/advisories/GHSA-mj63-m3rc-8ppr
- https://www.vulncheck.com/advisories/commonmark-2.0.0-before-2.8.4-denial-of-service-via-xml
Get alerted when CVE-2026-86432 or the next vulnerability affects your stack