What’s Vulnerable › Vulnerabilities
CVE-2026-86437: Lara Dashboard before 1.3.2 Incorrect Authorization in Core-Upgrade Archive Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-09-08
- Weakness: CWE-863
Description
Lara Dashboard before 1.3.2 authorizes the POST /admin/settings/core-upgrades/upload endpoint with only the settings.edit permission, allowing non-Superadmin administrators to upload and extract arbitrary zip archives over the live application source code. Attackers can upload a malicious archive containing modified application files such as routes/web.php with embedded system commands, which execute as the web server user with access to environment secrets and database credentials.
Affected products
- laradashboard: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: laradashboard 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/laradashboard/laradashboard
- https://github.com/laradashboard/laradashboard/blob/v1.3.1/app/Http/Requests/CoreUpgrade/UploadRequest.php#L15-L18
- https://github.com/laradashboard/laradashboard/blob/v1.3.1/app/Policies/SettingPolicy.php#L47-L50
- https://github.com/laradashboard/laradashboard/blob/v1.3.1/app/Services/CoreUpgradeService.php#L543-L577
- https://github.com/laradashboard/laradashboard/commit/738cc1a219ce459323ef1d09c3789075f1b8d2f2
- https://github.com/laradashboard/laradashboard/releases/tag/v1.3.2
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-xv98-x5h7-4g7v
- https://www.vulncheck.com/advisories/lara-dashboard-before-1.3.2-incorrect-authorization-in-core-upgrade-archive-upload
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-xv98-x5h7-4g7v
Get alerted when CVE-2026-86437 or the next vulnerability affects your stack