What’s Vulnerable › Vulnerabilities
CVE-2026-8646: IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by multiple vulnerabilities
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-06-24
- Weakness: CWE-444
Description
IBM WebSphere Application Server 9.0 and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.6 are vulnerable to HTTP request smuggling. A remote attacker could smuggle a specially crafted request to the application server thereby allowing the attacker to bypass security controls, spoof identity, escalate privilege, and expose sensitive information.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.30; from 9.0.0.0 before 9.0.5.29; from 17.0.0.3 before 26.0.0.7 — fixed in 26.0.0.7, 8.5.5.30, 9.0.5.29
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.7, 8.5.5.30, 9.0.5.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8646 or the next vulnerability affects your stack