What’s Vulnerable › Vulnerabilities
CVE-2026-86471: Apache CouchDB: Admin credentials leading to code execution as operating system user
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-21
- Weakness: CWE-78
Description
An unvalidated runtime configuration value in Apache CouchDB 3.5.2 and below on all platforms allows a CouchDB server admin to run arbitrary shell commands as the CouchDB operating system user. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
Affected products
- Apache Software Foundation Apache CouchDB: before 3.5.3 — fixed in 3.5.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CouchDB 3.5.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/pj83174r8f8f64odf47fwhozbfjtot0f
- https://lists.apache.org/thread/c8p73gswgogtnzvk7hpw8jb8d4mnosdp
- http://www.openwall.com/lists/oss-security/2026/10/20/11
Get alerted when CVE-2026-86471 or the next vulnerability affects your stack