What’s Vulnerable › Vulnerabilities
CVE-2026-86530
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-09-30
- Weakness: CWE-78
Description
BUFFALO Wi-Fi products handle some web form input improperly to assemble command line strings internally. An administrative user may send a crafted HTTP request and execute an arbitrary OS command.
Affected products
- BUFFALO INC. WEX-G300: before Ver.1.71 — fixed in Ver.1.71
- BUFFALO INC. WSR-300HP: before Ver.2.55 — fixed in Ver.2.55
How to fix
Upgrade to a fixed version: BUFFALO INC. WEX-G300 Ver.1.71; BUFFALO INC. WSR-300HP Ver.2.55. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-86530 or the next vulnerability affects your stack