What’s Vulnerable › Vulnerabilities
CVE-2026-86537: Apache Thrift: A truncated HTTP request stops the D library's server, allowing an unauthenticated remote attacker to deny service
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-02 · updated 2026-10-02
- Weakness: CWE-191
Description
Uncaught exception, Loop with unreachable exit condition ('infinite loop'), Integer underflow (wrap or wraparound) vulnerability in Apache Thrift D language bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.25.0 — fixed in 0.25.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.25.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1
- https://lists.apache.org/thread/k14jfr1xwc0vtmm2s7xro6lt7q4y6s7m
Get alerted when CVE-2026-86537 or the next vulnerability affects your stack