What’s Vulnerable › Vulnerabilities
CVE-2026-86540: knowns before 0.30.0 Arbitrary Code Execution via LSP Binary
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-09-08
- Weakness: CWE-78
Description
knowns versions before 0.30.0 fail to validate the settings.lsp.languages binary field in project configuration files, allowing attackers to execute arbitrary binaries by crafting a malicious .knowns/config.json file. When a repository with a crafted configuration is opened, the unvalidated binary path is executed twice under the user's account without any verification.
Affected products
- knowns-dev knowns: before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: knowns-dev knowns 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/knowns-dev/knowns/blob/v0.29.1/internal/lsp/detect.go#L128-L157
- https://github.com/knowns-dev/knowns/blob/v0.29.1/internal/models/config.go#L205-L216
- https://github.com/knowns-dev/knowns/commit/d3989829fb5095666d23d005b2f78a082832a396
- https://github.com/knowns-dev/knowns/releases/tag/v0.30.0
- https://github.com/knowns-dev/knowns/security/advisories/GHSA-mc52-mwq4-vfx3
- https://www.vulncheck.com/advisories/knowns-before-0.30.0-arbitrary-code-execution-via-lsp-binary
Get alerted when CVE-2026-86540 or the next vulnerability affects your stack