What’s Vulnerable › Vulnerabilities
CVE-2026-86541: knowns before 0.30.0 Path Traversal via code.replace MCP action
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-09-10
- Weakness: CWE-22
Description
knowns versions before 0.30.0 contain a path traversal vulnerability in the handleCodeReplace() function that allows attackers to overwrite arbitrary files outside the project root. Attackers can supply absolute paths or relative paths containing directory traversal sequences to write malicious content to sensitive files like shell startup scripts or SSH configuration files.
Affected products
- knowns-dev knowns: before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: knowns-dev knowns 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/knowns-dev/knowns/blob/v0.29.1/internal/mcp/handlers/code.go#L588-L646
- https://github.com/knowns-dev/knowns/commit/a2c98fc5c313463576c9348beeec6a74ddd7333b
- https://github.com/knowns-dev/knowns/releases/tag/v0.30.0
- https://github.com/knowns-dev/knowns/security/advisories/GHSA-f539-xgc6-xw7q
- https://www.vulncheck.com/advisories/knowns-before-0.30.0-path-traversal-via-code-replace-mcp-action
Get alerted when CVE-2026-86541 or the next vulnerability affects your stack