What’s Vulnerable › Vulnerabilities
CVE-2026-86544: knowns before 0.30.0 Authorization Bypass via Misclassified Code Actions
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-07 · updated 2026-09-09
- Weakness: CWE-863
Description
knowns versions before 0.30.0 contain an authorization bypass vulnerability where mutating code actions are incorrectly classified as read-only operations. Attackers with read-restricted sessions can exploit code.replace to modify permission configurations and escalate privileges on subsequent calls.
Affected products
- knowns-dev knowns: before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: knowns-dev knowns 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/knowns-dev/knowns/blob/v0.29.1/internal/permissions/guard.go#L44-L60
- https://github.com/knowns-dev/knowns/blob/v0.29.1/internal/permissions/registry.go#L99-L140
- https://github.com/knowns-dev/knowns/commit/a2c98fc5c313463576c9348beeec6a74ddd7333b
- https://github.com/knowns-dev/knowns/releases/tag/v0.30.0
- https://github.com/knowns-dev/knowns/security/advisories/GHSA-w323-3wpx-f7g5
- https://www.vulncheck.com/advisories/knowns-before-0.30.0-authorization-bypass-via-misclassified-code-actions
Get alerted when CVE-2026-86544 or the next vulnerability affects your stack