What’s Vulnerable › Vulnerabilities
CVE-2026-8656
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package jsondiffpatch before 0.7.6 are vulnerable to Cross-site Scripting (XSS) via the annotated formatter due to improper sanitization of JSON values and property names. If an application compares untrusted JSON/object data and renders annotated formatter output in the DOM, attacker-controlled HTML can be interpreted by the browser, resulting in XSS.
Affected products
- jsondiffpatch: before 0.7.6 — fixed in 0.7.6
How to fix
Upgrade to a fixed version: jsondiffpatch 0.7.6. Check the vendor advisory for mitigations.
References
- https://gist.github.com/yuki-matsuhashi/72ed072d919f3c52adba298faa6a7da5
- https://github.com/benjamine/jsondiffpatch/commit/232338b34c4653148ca2f44e897a765b72c8c98f
- https://security.snyk.io/vuln/SNYK-JS-JSONDIFFPATCH-16635946
- https://gist.github.com/yuki-matsuhashi/72ed072d919f3c52adba298faa6a7da5
Get alerted when CVE-2026-8656 or the next vulnerability affects your stack