What’s Vulnerable › Vulnerabilities
CVE-2026-86589: Apache Answer: User Center integration does not revoke first-login sessions after central account suspension
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-19 · updated 2026-10-30
- Weakness: CWE-303
Description
Incorrect implementation of authentication algorithm vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.2. A flaw in the User Center login integration can cause a newly created external user session to omit its external identity, allowing subsequent requests to bypass central account suspension or deletion checks until the session expires or is revoked. Users are recommended to upgrade to version 2.0.3, which fixes the issue.
Affected products
- Apache Software Foundation Apache Answer: through 2.0.2
References
- https://lists.apache.org/thread/t8mbzfolzlqz4z5hcwq3v0lnwjqb2tl5
- http://www.openwall.com/lists/oss-security/2026/10/16/33
Get alerted when CVE-2026-86589 or the next vulnerability affects your stack