What’s Vulnerable › Vulnerabilities
CVE-2026-86600: Workload identity attestation generated before login host validation in Snowflake drivers
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-10
- Weakness: CWE-441
Description
In affected Snowflake drivers, WORKLOAD_IDENTITY authentication requests a cloud workload-identity token and attaches it to the login request without verifying that the configured host is a Snowflake endpoint. An attacker who can modify the connection configuration can cause the driver to mint a fresh attestation and send it to a host they control. The captured token can be replayed to Snowflake for its remaining lifetime in accounts where that workload identity is already registered. On Azure, the token audience is also taken from connection configuration. Combined with an attacker-controlled host, the driver can request a Managed Identity access token scoped to a non-Snowflake Azure resource and deliver it to the attacker. That path is the only case in which impact extends beyond Snowflake; it is bounded by the token lifetime and the managed identity’s permissions. Successful exploitation requires WORKLOAD_IDENTITY authentication on a workload that already has an ambient cloud identity. Patched driver versions restrict this authenticator to recognized Snowflake hosts. Users must manually upgrade.
Affected products
- Snowflake Connector for .NET: from 4.7.0 before 6.1.0 — fixed in 6.1.0
- Snowflake Connector for Python: from 3.14.1 before 4.7.3 — fixed in 4.7.3
- Snowflake Go Driver: from 1.15.0 through 1.19.1; from 2.0.0 before 2.2.0 — fixed in 2.2.0
- Snowflake JDBC Driver: from 3.24.0 before 4.3.4 — fixed in 4.3.4
- Snowflake JDBC Driver (FIPS): from 3.24.0 before 4.3.4 — fixed in 4.3.4
- Snowflake JDBC Driver (Thin): from 3.24.0 before 4.3.4 — fixed in 4.3.4
- Snowflake libsnowflakeclient: from 2.2.0 before 2.10.0 — fixed in 2.10.0
- Snowflake Node.js Driver: from 2.1.1 before 3.3.0 — fixed in 3.3.0
- Snowflake ODBC Driver: from 3.9.0 before 3.20.0 — fixed in 3.20.0
- Snowflake PHP PDO Driver: from 3.6.0 before 4.2.0 — fixed in 4.2.0
How to fix
Upgrade to a fixed version: Snowflake Connector for .NET 6.1.0; Snowflake Connector for Python 4.7.3; Snowflake Go Driver 2.2.0; Snowflake JDBC Driver 4.3.4; Snowflake JDBC Driver (FIPS) 4.3.4; Snowflake JDBC Driver (Thin) 4.3.4; Snowflake libsnowflakeclient 2.10.0; Snowflake Node.js Driver 3.3.0; Snowflake ODBC Driver 3.20.0; Snowflake PHP PDO Driver 4.2.0. Check the vendor advisory for mitigations.
References
- https://docs.snowflake.com/en/release-notes/clients-drivers/dotnet-2026#version-610-september-3-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/golang-2026#version-220-sep-03-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/jdbc-2026#version-434-sep-03-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/nodejs-2026#version-330-september-3-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/odbc-2026#version-3200-sep-3-2026
- https://docs.snowflake.com/en/release-notes/clients-drivers/php-pdo-2026#version-420-sep-3-2026
- https://github.com/snowflakedb/libsnowflakeclient/releases/tag/v2.10.0
- https://github.com/snowflakedb/snowflake-connector-python/releases/tag/v4.7.3
Get alerted when CVE-2026-86600 or the next vulnerability affects your stack