What’s Vulnerable › Vulnerabilities

CVE-2026-8667: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.6 before 19.0.6, 19.1 before 19.1.4, and 19.2 before 19.2.2 that under certain conditions could have allowed an authenticated user with developer role to modify certain package registry metadata without the required maintainer-level permissions due to improper authorization checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.0.6, 19.1.4, 19.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-8667 or the next vulnerability affects your stack