What’s Vulnerable › Vulnerabilities
CVE-2026-86730: Craft CMS 5.0.0-RC1 before 5.10.12 Behavior Injection RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-08
- Weakness: CWE-94
Description
Craft CMS versions before 5.10.12 fail to properly cleanse string-typed field-layout elements, allowing authenticated control-panel users to inject Yii2 behavior attachments and event handlers. Attackers can post field-layout tab elements as JSON strings to bypass cleanse validation, then trigger arbitrary object instantiation and code execution through Craft::createObject().
Affected products
- craftcms cms: from 5.0.0-RC1 before 5.10.12 — fixed in 5.10.12
How to fix
Upgrade to a fixed version: craftcms cms 5.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-qj4v-m29p-fj4m
- https://www.vulncheck.com/advisories/craft-cms-5.0.0-rc1-before-5.10.12-behavior-injection-rce
Get alerted when CVE-2026-86730 or the next vulnerability affects your stack