What’s Vulnerable › Vulnerabilities

CVE-2026-86731: Craft CMS 5.0.0-RC1 before 5.10.12 Permission Escalation via UsersController

Description

Craft CMS versions 5.0.0-RC1 through 5.10.11 are missing an admin-target guard in UsersController::actionActivateUser (the users/activate-user action). While the action requires the administrateUsers permission, it does not call requireAdmin() when the targeted user is an administrator, unlike the mirror action actionDeactivateUser. As a result, an authenticated control panel user who is not an administrator but holds the administrateUsers permission can activate a pending or deliberately deactivated administrator account, which can lead to permission escalation when combined with resetting that account's password. The issue is fixed in Craft CMS 5.10.12.

Affected products

How to fix

Upgrade to a fixed version: craftcms cms 5.10.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-86731 or the next vulnerability affects your stack