What’s Vulnerable › Vulnerabilities
CVE-2026-86732: Craft CMS before 5.10.12 Remote Code Execution via element-index
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-10
- Weakness: CWE-94
Description
Craft CMS versions before 5.10.12 contain a remote code execution vulnerability in the element-index endpoint that allows authenticated content editors to instantiate arbitrary classes through the criteria parameter. Attackers can inject a malicious class via criteria[withTransforms][0][class] that reaches ImageTransforms::normalizeTransform(), then use a PHP gadget chain with yii\rbac\PhpManager to execute code by pointing itemFile to a request log containing PHP payload in the User-Agent header.
Affected products
- craftcms cms: from 5.0.0-RC1 before 5.10.12 — fixed in 5.10.12
How to fix
Upgrade to a fixed version: craftcms cms 5.10.12. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-9wcj-wqqh-cqvg
- https://www.vulncheck.com/advisories/craft-cms-before-5.10.12-remote-code-execution-via-element-index
Get alerted when CVE-2026-86732 or the next vulnerability affects your stack