What’s Vulnerable › Vulnerabilities
CVE-2026-86738: Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-09
- Weakness: CWE-79
Description
Snipe-IT versions before 8.7.0 contain a CSS injection vulnerability in the Custom CSS field due to incomplete sanitization that reverses HTML encoding on greater-than and double-quote characters. Superusers can plant malicious CSS payloads using @import and url() references to exfiltrate CSRF tokens from other superusers via attribute-selector rules, enabling account takeover.
Affected products
- grokability snipe-it: from 3.0.0 before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/commit/d26d71688359707f3b257fc04fe6c3e5a17405f9
- https://github.com/grokability/snipe-it/security/advisories/GHSA-pvcw-mp8q-mj39
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-css-injection-via-custom-css
Get alerted when CVE-2026-86738 or the next vulnerability affects your stack