What’s Vulnerable › Vulnerabilities
CVE-2026-86752: snipe-it before 8.7.0 Authorization Bypass via Asset Audit Endpoints
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-14
- Weakness: CWE-863
Description
snipe-it versions before 8.7.0 fail to enforce per-instance FMCS scoping in asset audit endpoints, relying solely on query-layer filtering instead of policy-layer authorization checks. Attackers with valid sessions and assets.audit permissions could write audit log entries against cross-company assets if the query-layer scope were bypassed or refactored.
Affected products
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-q745-gx2m-xj93
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-authorization-bypass-via-asset-audit-endpoints
Get alerted when CVE-2026-86752 or the next vulnerability affects your stack