What’s Vulnerable › Vulnerabilities
CVE-2026-86754: Snipe-IT before 8.7.0 Authorization Bypass via OAuth Clients
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-09 · updated 2026-09-20
- Weakness: CWE-863
Description
Snipe-IT before 8.7.0 fails to properly gate Laravel Passport's OAuth client management routes, allowing any authenticated user to register OAuth clients with attacker-controlled redirect URIs. Attackers can trick administrators into approving consent screens, then exchange authorization codes for bearer tokens inheriting full admin API permissions lasting up to 40 years.
Affected products
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-gq7g-hxjg-8j27
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-authorization-bypass-via-oauth-clients
Get alerted when CVE-2026-86754 or the next vulnerability affects your stack