What’s Vulnerable › Vulnerabilities
CVE-2026-86768: Snipe-IT before 8.7.0 Improper Input Validation via API Checkout
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-09 · updated 2026-09-16
- Weakness: CWE-20
Description
Snipe-IT before 8.7.0 fails to validate soft-deleted state in API checkout endpoints, allowing authenticated users with checkout permissions to bind live inventory to trashed targets. Attackers can submit POST requests to hardware, component, or consumable checkout endpoints with soft-deleted user, asset, or location IDs to create orphaned references that corrupt the asset ledger and audit trails.
Affected products
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-qffp-xpqv-gqr4
- https://www.vulncheck.com/advisories/snipe-it-before-8.7.0-improper-input-validation-via-api-checkout
- https://github.com/grokability/snipe-it/security/advisories/GHSA-qffp-xpqv-gqr4
Get alerted when CVE-2026-86768 or the next vulnerability affects your stack