What’s Vulnerable › Vulnerabilities
CVE-2026-86773: Snipe-IT 8.6.3 Broken Access Control via Kit Update Endpoints
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-09 · updated 2026-09-16
- Weakness: CWE-863
Description
Snipe-IT through version 8.6.3 fails to perform object-level authorization in the updateLicense, updateConsumable, updateAccessory, and updateModel endpoints and in the storeModel endpoint for Predefined Kits. The existing check authorizes only the parent Predefined Kit (update on PredefinedKit) and not the child object being attached. As a result, an authenticated user holding only the kits.edit permission can attach a License, Consumable, Accessory, or Asset Model that they are otherwise denied (HTTP 403) from reading directly to a Predefined Kit, and the kit relation index then discloses the attached object's name back to that low-privilege user. This is the update-path and storeModel counterpart to CVE-2026-55478, which fixed only the storeLicense, storeConsumable, and storeAccessory methods in 8.6.2. Note that updateModel was code-vulnerable in 8.6.3 but not reachable in practice because a route-name typo bound the route to a nonexistent controller method, causing HTTP 500 responses. The issue is fixed in Snipe-IT 8.7.0.
Affected products
- grokability snipe-it: before 8.7.0 — fixed in 8.7.0
How to fix
Upgrade to a fixed version: grokability snipe-it 8.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/grokability/snipe-it/security/advisories/GHSA-4j5f-mm59-hf9w
- https://www.vulncheck.com/advisories/snipe-it-8.6.3-broken-access-control-via-kit-update-endpoints
- https://github.com/grokability/snipe-it/security/advisories/GHSA-4j5f-mm59-hf9w
Get alerted when CVE-2026-86773 or the next vulnerability affects your stack