What’s Vulnerable › Vulnerabilities
CVE-2026-86783: PostX < 5.0.41 - Unauthenticated Custom Field Key Disclosure via REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-200
Description
The Post Grid Gutenberg Blocks WordPress plugin before 5.0.41 does not perform an authorization or post-visibility check on a REST API route that returns the custom field keys of a given post, allowing unauthenticated users to disclose the custom field key names of arbitrary posts, including private, draft, pending, scheduled and password-protected posts.
Affected products
- Post Grid Gutenberg Blocks: before 5.0.41 — fixed in 5.0.41
How to fix
Upgrade to a fixed version: Post Grid Gutenberg Blocks 5.0.41. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-86783 or the next vulnerability affects your stack