What’s Vulnerable › Vulnerabilities
CVE-2026-86784: Visualizer < 4.0.8 - Contributor+ Stored XSS via JSON Data Source
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-17
- Weakness: CWE-79
Description
The Visualizer WordPress plugin before 4.0.8 does not sanitise and escape a chart's JSON data source configuration before outputting it back in the chart editor, allowing users with the Contributor role and above to store JavaScript that executes in the browser of any higher-privileged user, such as an administrator, who reviews the affected chart.
Affected products
- Visualizer: before 4.0.8 — fixed in 4.0.8
How to fix
Upgrade to a fixed version: Visualizer 4.0.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-86784 or the next vulnerability affects your stack