What’s Vulnerable › Vulnerabilities
CVE-2026-86787: Affiliate Toolkit 3.8.7 - 3.9.0 - Contributor+ RCE via BladeOne @php Directive
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-14
- Weakness: CWE-94
Description
The affiliate-toolkit WordPress plugin before 3.9.1 does not prevent a low-privileged user from supplying a template body that its bundled templating engine compiles and executes as PHP, allowing users with the Contributor role or above to run arbitrary PHP code on the server.
Affected products
- cservit affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display: from 3.8.7 before 3.9.1 — fixed in 3.9.1
How to fix
Upgrade to a fixed version: cservit affiliate-toolkit – Multi-Network Affiliate & Amazon Product Display 3.9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-86787 or the next vulnerability affects your stack