What’s Vulnerable › Vulnerabilities
CVE-2026-86792: Apache Airflow Apache Kafka provider: Connection-editor remote code execution on the Scheduler via Kafka connection callback configuration
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-18
- Weakness: CWE-470
Description
Apache Airflow Apache Kafka provider versions 1.15.0 before 2.0.0 resolve dotted-path strings found in a Kafka connection's `extra` field into Python callables via `import_string`, with no allowlist, and hand them to the confluent-kafka client which invokes them. Deployments that have enabled the Kafka event producer — `dag_run_events_enabled` or `task_instance_events_enabled`, both disabled by default — build that client inside the scheduler process, so a user whose only privilege is editing Airflow connections gains arbitrary code execution in the control plane; the Airflow security model limits connection-configuration users to code execution on workers, not the scheduler. Deployments using Google Managed Kafka are not affected, because that code path overwrites any user-supplied `oauth_cb`; plain brokers and Amazon MSK are exposed. Users are recommended to upgrade to apache-airflow-providers-apache-kafka 2.0.0 or later, which adds an allowlist configuration option for connection-string callbacks.
Affected products
- Apache Software Foundation Apache Airflow Apache Kafka provider: from 1.15.0 before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Apache Kafka provider 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/72208
- https://lists.apache.org/thread/jl4gpok02313yh3rvtvj8qbo11c6zpr2
- https://lists.apache.org/thread/jl4gpok02313yh3rvtvj8qbo11c6zpr2?users@airflow.apache.org
- http://www.openwall.com/lists/oss-security/2026/09/15/15
Get alerted when CVE-2026-86792 or the next vulnerability affects your stack