What’s Vulnerable › Vulnerabilities

CVE-2026-86797: Pricing Table Block 1.0.7 - 2.1.4 - Contributor+ Stored XSS via Pricing Link

Description

The Pricing Table WordPress plugin before 2.1.5 does not validate the scheme of a user-supplied link value in one of its blocks before rendering it, allowing users with contributor-level access and above to store malicious scripts that execute when another user views and interacts with the affected content.

Affected products

How to fix

Upgrade to a fixed version: Pricing Table 2.1.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-86797 or the next vulnerability affects your stack