What’s Vulnerable › Vulnerabilities
CVE-2026-86831: Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-10-20
- Weakness: CWE-1289
Description
Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS Network Policy Agent before v1.4.0 might allow an authenticated remote user to bypass NetworkPolicy enforcement on co-located pods in other namespaces via crafted pod and namespace names that produce pod identifier collisions. To remediate this issue, users should upgrade to Amazon EKS Network Policy Agent 1.4.0 or later and Amazon VPC CNI Managed Add-on v1.22.4 or later (which includes Network Policy Agent v1.4.0).
Affected products
- AWS amazon-vpc-cni-k8s: from 1.14.0 before 1.22.4 — fixed in 1.22.4
- aws-network-policy-agent: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: AWS amazon-vpc-cni-k8s 1.22.4; aws-network-policy-agent 1.4.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-113-aws/
- https://github.com/aws/amazon-vpc-cni-k8s/releases/tag/v1.22.4
- https://github.com/aws/amazon-vpc-cni-k8s/security/advisories/GHSA-gjc7-c7mx-x8f3
- https://github.com/aws/aws-network-policy-agent/releases/tag/v1.4.0
- https://github.com/aws/aws-network-policy-agent/security/advisories/GHSA-7xv7-8r3j-3j25
Get alerted when CVE-2026-86831 or the next vulnerability affects your stack