What’s Vulnerable › Vulnerabilities
CVE-2026-8700: Crypt::DSA versions before 1.20 for Perl generate seeds using rand
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-15 · updated 2026-10-26
- Weakness: CWE-331
Description
Crypt::DSA versions before 1.20 for Perl generate seeds using rand. Seeds were generated using Perl's built-in rand function, which is predictable and unsuitable for security usage.
Affected products
- TIMLEGGE Crypt::DSA: before 1.20 — fixed in 1.20
How to fix
Upgrade to a fixed version: TIMLEGGE Crypt::DSA 1.20. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/TIMLEGGE/Crypt-DSA-1.20/changes
- https://metacpan.org/release/TIMLEGGE/Crypt-DSA-1.20/diff/TIMLEGGE/Crypt-DSA-1.19#lib/Crypt/DSA/KeyChain.pm
- http://www.openwall.com/lists/oss-security/2026/05/15/26
Get alerted when CVE-2026-8700 or the next vulnerability affects your stack