What’s Vulnerable › Vulnerabilities
CVE-2026-87018: undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-248
Description
undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.
Affected products
- undici: from 4.2.1 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
- Npm Undici: from 4.2.1 before 6.29.1; from 7.0.0 before 7.30.1; from 8.0.0 before 8.12.2 — fixed in 6.29.1, 7.30.1, 8.12.2
How to fix
Upgrade to a fixed version: undici 6.29.1, 7.30.1, 8.12.2; Npm Undici 6.29.1, 7.30.1, 8.12.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/nodejs/undici/security/advisories/GHSA-qrxm-fqhp-jwvm
Get alerted when CVE-2026-87018 or the next vulnerability affects your stack