What’s Vulnerable › Vulnerabilities
CVE-2026-8711: NGINX JavaScript vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-23
- Weakness: CWE-122
Description
NGINX JavaScript has a vulnerability when the js_fetch_proxy directive is configured with at least one client-controlled NGINX variable (for example, $http_*, $arg_*, $cookie_*) and a location invoking the ngx.fetch() operation from NGINX JavaScript. An unauthenticated attacker can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 Njs: from 0.9.4 before 0.9.9 — fixed in 0.9.9
How to fix
Upgrade to a fixed version: F5 Njs 0.9.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8711 or the next vulnerability affects your stack