What’s Vulnerable › Vulnerabilities
CVE-2026-87668
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-13
- Weakness: CWE-121
Description
A stack-based buffer overflow vulnerability exists in the diagnostic execution utility of Brocade Fabric OS versions before 10.0.1. When processing command arguments for diagnostic operations, the utility tokenizes user-supplied input into an internal argument array without enforcing boundary checks on the maximum array capacity. An authenticated user with administrative access can exploit this vulnerability by supplying a crafted diagnostic command string containing an excessive number of tokenized arguments. This leads to a memory overwrite resulting in a denial of service (process crash).
Affected products
- Brocade Fabric OS: before 10.0.1 — fixed in 10.0.1
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87668 or the next vulnerability affects your stack