What’s Vulnerable › Vulnerabilities
CVE-2026-87673
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-78
Description
An OS command injection vulnerability exists in maintenance command-line diagnostic utilities on Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1. The binary fails to sanitize user-supplied input options when invoking underlying system commands through a shell interpreter. A privileged user with maintenance account access can exploit this issue by supplying crafted parameters, which results in arbitrary OS command execution with root privileges.
Affected products
- Brocade Fabric OS: before 9.2.2d; from 10.0.0 before 10.0.1 — fixed in 10.0.1, 9.2.2d
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1, 9.2.2d. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87673 or the next vulnerability affects your stack