What’s Vulnerable › Vulnerabilities
CVE-2026-87677
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-78
Description
An OS command injection vulnerability exists in the account management subsystem of Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1. When an administrator initiates an account deletion, the system invokes an internal maintenance routine to clean up cryptographic keys associated with the target account. Malformed account names previously accepted by Fabric OS can cause the execution of embedded shell metacharacters, triggering command injection.
Affected products
- Brocade Fabric OS: before 9.2.2d; from 10.0.0 before 10.0.1 — fixed in 10.0.1, 9.2.2d
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1, 9.2.2d. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87677 or the next vulnerability affects your stack