What’s Vulnerable › Vulnerabilities
CVE-2026-87678
- Severity: medium (CVSS 5.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-93
Description
An input validation and output encoding vulnerability exists in the web management interface of Brocade Fabric OS versions before 10.0.1. When configuring Federated Authentication (FA), the system fails to sanitize the Identity Provider (IdP) issuer parameter. An authenticated administrator—or an attacker capable of supplying crafted FA configuration files during an import routine—can inject arbitrary web server directives. This can lead to service denial by preventing the web management daemon from starting, or potentially alter web server security controls.
Affected products
- Brocade Fabric OS: before 10.0.1 — fixed in 10.0.1
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87678 or the next vulnerability affects your stack