What’s Vulnerable › Vulnerabilities
CVE-2026-87683
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-13
- Weakness: CWE-121
Description
Multiple stack-based buffer overflow vulnerabilities exist in the REST API management component of Brocade Fabric OS versions prior to 10.0.1. When processing API request payloads (such as device configuration attributes or port mapping requests) the REST API service fails to properly validate incoming array counts and string lengths against internal buffer capacities. An authenticated attacker with REST API access can transmit crafted, oversized request parameters to induce memory corruption on the execution stack. This may result in a denial-of-service condition (daemon crash) or potential arbitrary code execution within the management process context.
Affected products
- Brocade Fabric OS: before 10.0.1 — fixed in 10.0.1
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87683 or the next vulnerability affects your stack