What’s Vulnerable › Vulnerabilities
CVE-2026-87687
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-14
- Weakness: CWE-88
Description
An authorization and input validation vulnerability exists in Brocade Fabric OS versions before 9.2.2d and 10.0.0 through 10.0.0a1. An authenticated user with restricted privileges in one Virtual Fabric can exploit this issue by submitting a specially crafted request containing an arbitrary fabric identifier. This allows the user to perform unauthorized cross-fabric operations and view configuration details within tenants/Virtual Fabrics to which they have not been granted access.
Affected products
- Brocade Fabric OS: before 9.2.2d; from 10.0.0 before 10.0.1 — fixed in 10.0.1, 9.2.2d
How to fix
Upgrade to a fixed version: Brocade Fabric OS 10.0.1, 9.2.2d. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87687 or the next vulnerability affects your stack