What’s Vulnerable › Vulnerabilities
CVE-2026-87777: Hostinger Reach 1.0.6 - 1.8.2 - Contributor+ Stored XSS via formId Elementor Widget Attribute
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-79
Description
The Hostinger Reach WordPress plugin before 1.8.3 does not sanitize and escape a widget setting before outputting it in the editor preview, allowing users with contributor-level access and above to inject arbitrary web scripts that will execute in the session of a higher-privileged user who opens the affected content in the editor.
Affected products
- Hostinger Reach: from 1.0.6 before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: Hostinger Reach 1.8.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87777 or the next vulnerability affects your stack