What’s Vulnerable › Vulnerabilities
CVE-2026-87780: LTL Freight Quotes – Old Dominion Edition < 4.2.19 - Unauthenticated Stored XSS via Shipping Rules
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-10 · updated 2026-10-13
- Weakness: CWE-79
Description
The LTL Freight Quotes WordPress plugin before 4.2.19 does not sanitise and escape values submitted through an unauthenticated endpoint before storing them and outputting them back in an administrative page, leading to Stored XSS which will execute in the session of any administrator viewing it.
Affected products
- LTL Freight Quotes: before 4.2.19 — fixed in 4.2.19
How to fix
Upgrade to a fixed version: LTL Freight Quotes 4.2.19. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87780 or the next vulnerability affects your stack