What’s Vulnerable › Vulnerabilities
CVE-2026-87821: Lara Dashboard 0.9.2 through 1.3.1 Server-Side Request Forgery in Builder Markdown Fetch
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-09
- Weakness: CWE-918
Description
Lara Dashboard through 1.3.1 contains a server-side request forgery vulnerability in the POST /api/admin/builder/markdown/fetch endpoint that allows any authenticated user to fetch arbitrary URLs and read the response body. Attackers can read internal HTTP services and cloud metadata including IAM credentials by supplying malicious URLs without host validation or redirect restrictions.
Affected products
- laradashboard: from 0.9.2 before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: laradashboard 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/laradashboard/laradashboard
- https://github.com/laradashboard/laradashboard/blob/v0.9.2/app/Services/Builder/MarkdownFetchService.php
- https://github.com/laradashboard/laradashboard/blob/v1.3.1/app/Http/Controllers/Api/Builder/MarkdownController.php
- https://github.com/laradashboard/laradashboard/blob/v1.3.1/app/Services/Builder/MarkdownFetchService.php
- https://github.com/laradashboard/laradashboard/blob/v1.3.2/app/Support/Security/SafeUrlValidator.php
- https://github.com/laradashboard/laradashboard/commit/738cc1a219ce459323ef1d09c3789075f1b8d2f2
- https://github.com/laradashboard/laradashboard/releases/tag/v1.3.2
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-4xqv-4c27-6c4j
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-f36j-h77g-6wj8
- https://www.vulncheck.com/advisories/lara-dashboard-0.9.2-through-1.3.1-server-side-request-forgery-in-builder-markdown-fetch
- https://github.com/laradashboard/laradashboard/security/advisories/GHSA-4xqv-4c27-6c4j
Get alerted when CVE-2026-87821 or the next vulnerability affects your stack