What’s Vulnerable › Vulnerabilities
CVE-2026-87830: Apache WSS4J: Streaming WS-SecurityPolicy validation may skip element-protection checks.
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-10-06
- Weakness: CWE-917
Description
In the StAX streaming WS-SecurityPolicy validator, certain relative or unsupported XPath expressions can be converted into paths that never match the actual XML element path. A remote SOAP peer may therefore send a required element without the expected signature or encryption. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Affected products
- Apache Software Foundation Apache WSS4J: before 2.4.4; from 3.0.0 before 3.0.6; from 4.0.0 before 4.0.2 — fixed in 2.4.4, 3.0.6, 4.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache WSS4J 2.4.4, 3.0.6, 4.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/lwlozb1x20d16f9dnyvoygc9rrhzq2vn
- http://www.openwall.com/lists/oss-security/2026/09/30/9
Get alerted when CVE-2026-87830 or the next vulnerability affects your stack