What’s Vulnerable › Vulnerabilities
CVE-2026-87838: Wava Payment 0.3.1 - 0.3.9 - Unauthenticated Merchant Credential Overwrite via Install Webhook
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-21
- Weakness: CWE-862
Description
The Wava Payment Plugin WordPress plugin before 0.3.10 does not perform any authorisation, nonce or origin verification on one of its public REST endpoints, allowing unauthenticated attackers to overwrite the stored credential that identifies the merchant account the store's payments are created against, to force the integration into a verified state the site owner never completed, and to remove the payment method from the store's checkout.
Affected products
- Wava Payment Plugin: from 0.3.1 before 0.3.10 — fixed in 0.3.10
How to fix
Upgrade to a fixed version: Wava Payment Plugin 0.3.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87838 or the next vulnerability affects your stack