What’s Vulnerable › Vulnerabilities
CVE-2026-87888: YayPricing < 3.5.7 - Subscriber+ Stored XSS via save_page_data REST Route
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-14
- Weakness: CWE-79
Description
The YayPricing WordPress plugin before 3.5.7 does not perform an authorization check on a REST route that saves its pricing rules, allowing users with the subscriber role and above to store JavaScript that executes in the browser of an administrator who opens the YayPricing WordPress plugin before 3.5.7's settings page.
Affected products
- YayPricing: before 3.5.7 — fixed in 3.5.7
How to fix
Upgrade to a fixed version: YayPricing 3.5.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87888 or the next vulnerability affects your stack