What’s Vulnerable › Vulnerabilities
CVE-2026-87902: WordPress Core Remote File Inclusion Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-25
- EPSS: 95.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-22 · updated 2026-09-28
- Weakness: CWE-98
Description
An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the active theme directories. If relevant pre-conditions for both the server and the active theme are met, this can lead to RCE.
Affected products
- WordPress: before 4.7.37; from 4.8 before 4.8.32; from 4.9 before 4.9.33; from 5.0 before 5.0.29; from 5.1 before 5.1.26; from 5.2 before 5.2.28 — fixed in 4.7.37, 4.8.32, 4.9.33, 5.0.29, 5.1.26, 5.2.28
How to fix
Upgrade to a fixed version: WordPress 4.7.37, 4.8.32, 4.9.33, 5.0.29. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-7hp8-65ch-5whp
- https://patchstack.com/articles/cve-2026-87902-attackers-started-probing-wordpress-sites-hours-after-the-patch/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-87902
Get alerted when CVE-2026-87902 or the next vulnerability affects your stack