What’s Vulnerable › Vulnerabilities
CVE-2026-87908: multiparty vulnerable to Denial of Service via unbounded part-header accumulation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-11 · updated 2026-09-16
- Weakness: CWE-400
Description
multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.
Affected products
- multiparty: from 2.1.0 before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: multiparty 4.3.1. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/pillarjs/multiparty/security/advisories/GHSA-5h46-2939-q3wh
Get alerted when CVE-2026-87908 or the next vulnerability affects your stack