What’s Vulnerable › Vulnerabilities
CVE-2026-87911: Read-only enforcement bypass enabling operating system command execution in the SQL validation component of Amazon awslabs postgres-mcp-server
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-10
- Weakness: CWE-78
Description
An OS command injection weakness in the read-only enforcement of the SQL validation component in Amazon awslabs postgres-mcp-server before 1.1.7 might allow an unauthenticated actor to execute operating system commands on the host of a self-managed PostgreSQL server by placing a crafted COPY ... TO PROGRAM statement into content that is processed when an authenticated user interacts with the MCP server in its default read-only mode. To remediate this issue, users should upgrade to version 1.1.7 or later.
Affected products
- AWS Labs postgres MCP Server: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: AWS Labs postgres MCP Server 1.1.7. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-104-aws/
- https://github.com/awslabs/mcp/security/advisories/GHSA-fph8-pg5w-78fv
- https://pypi.org/project/awslabs.postgres-mcp-server/1.1.7/
Get alerted when CVE-2026-87911 or the next vulnerability affects your stack