What’s Vulnerable › Vulnerabilities
CVE-2026-87918: WPBot < 8.5.7 - Unauthenticated AI Provider API Abuse via Multiple AJAX Actions
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-12 · updated 2026-09-14
- Weakness: CWE-284
Description
The WPBot WordPress plugin before 8.5.7 does not perform any authorization or nonce check on several AJAX actions that relay prompts to its configured AI providers, allowing unauthenticated attackers to make those third-party API calls, and consume the associated cost, using the site's own configured API keys.
Affected products
- WPBot: before 8.5.7 — fixed in 8.5.7
How to fix
Upgrade to a fixed version: WPBot 8.5.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87918 or the next vulnerability affects your stack