What’s Vulnerable › Vulnerabilities
CVE-2026-87939: Feed Block - Moderately critical - Cross-site scripting - SA-CONTRIB-2026-137
- Severity: medium (CVSS 4.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Feed Block allows Stored XSS. This issue affects Feed Block versions: from 0.0.0 to 2.0.2, from 3.0.0 to 3.0.2.
Affected products
- Drupal Feed Block: before 2.0.2; from 3.0.0 before 3.0.2 — fixed in 2.0.2, 3.0.2
How to fix
Upgrade to a fixed version: Drupal Feed Block 2.0.2, 3.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87939 or the next vulnerability affects your stack