What’s Vulnerable › Vulnerabilities
CVE-2026-87944: SAML SSO - Service Provider - Critical - Improper certificate validation - SA-CONTRIB-2026-142
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-22 · updated 2026-10-22
- Weakness: CWE-295
Description
Improper Certificate Validation vulnerability in Drupal SAML SSO - Service Provider allows Adversary in the Middle (AiTM). This issue affects SAML SSO - Service Provider versions: from 0.0.0 to 3.2.0.
Affected products
- Drupal SAML SSO - Service Provider: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: Drupal SAML SSO - Service Provider 3.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87944 or the next vulnerability affects your stack