What’s Vulnerable › Vulnerabilities
CVE-2026-87965: Easy Appointments < 4.0.2.2 - Unauthenticated Appointment Cancellation/Confirmation via Forgeable Email-Link Token
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-284
Description
The Easy Appointments WordPress plugin before 4.0.2.2 does not use an unguessable token to authorize its mail-link appointment cancellation and confirmation action, deriving the token from a hardcoded source-embedded salt and the appointment's creation timestamp, so unauthenticated attackers who know or guess that timestamp can cancel or confirm arbitrary appointments.
Affected products
- Easy Appointments: before 4.0.2.2 — fixed in 4.0.2.2
How to fix
Upgrade to a fixed version: Easy Appointments 4.0.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-87965 or the next vulnerability affects your stack